HUD1862:EXCEL排序
Problem Description
Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。
Input
测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N
行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。
Output
对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。
Sample Input
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
0 0
Sample Output
Case 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Case 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Case 3:
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90
这道题我真心想吐槽
哟在三个cmp函数中用三目运算符就一直WA
改成if才AC
无语
[cpp]
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
struct Student
{
char name[20];
char num[20];
int score;
} stu[100005];
bool cmp1(Student x,Student y)
{
if( strcmp(x.num , y.num) > 0 )
return 0;
else
return 1;
}
bool cmp2(Student x,Student y)
{
if( strcmp(x.name , y.name) > 0 )
return 0;
else if(strcmp(x.name , y.name) == 0)
{
if( strcmp(x.num , y.num) > 0 )
return 0;
}
return 1;
}
bool cmp3(Student x,Student y)
{
if( x.score>y.score )
return 0;
else if(x.score==y.score)
{
if( strcmp(x.num , y.num) > 0 )
return 0;
}
return 1;
}
int main()
{
int n,c,i,cnt = 1;
while(cin >> n >> c && n != 0 && c != 0)
{
for(i = 0; i<n; i++)
scanf("%s%s%d",stu[i].num,stu[i].name,&stu[i].score);
if(c == 1)
sort(stu,stu+n,cmp1);
else if(c == 2)
sort(stu,stu+n,cmp2);
else if (c == 3)
sort(stu,stu+n,cmp3);
printf("Case %d:\n",cnt++);
for(i = 0; i<n; i++)
printf("%.6s %s %d\n",stu[i].num,stu[i].name,stu[i].score);
}
return 0;
}
补充:软件开发 , C++ ,