poj2663 Tri Tiling dp递推
Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6314 Accepted: 3370
Description
In how many ways can you tile a 3xn rectangle with 2x1 dominoes?
Here is a sample tiling of a 3x12 rectangle.
Input
Input consists of several test cases followed by a line containing -1. Each test case is a line containing an integer 0 <= n <= 30.
Output
For each test case, output one integer number giving the number of possible tilings.
Sample Input
2
8
12
-1
Sample Output
3
153
2131
Source
Waterloo local 2005.09.24
练点思维性的题。
n为奇数肯定为0,n为偶数,每次都是加两列,我们把两列看为一列,如果这一列与前面分开就只有三种方法即3*a[n-2],如果这一列不与前面的分开,那么不可分解矩形都只有两种情况所以为2*(a[n-4]+a[n-6]+……a[0])
化简即为a[n]=4*a[n-2]-a[n-4]
[cpp]
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#define ll long long
using namespace std;
ll a[31];
int main()
{
ll n;
a[0]=1;a[2]=3;
for(int i=4;i<=30;i+=2)
a[i]=4*a[i-2]-a[i-4];
while(scanf("%lld",&n))
{
if(n==-1) break;
printf("%lld\n",a[n]);
}
}
补充:软件开发 , C++ ,