当前位置:编程学习 > C/C++ >>

hdu 1081 To The Max 线性DP 蛮不错的题

To The Max
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 30   Accepted Submission(s) : 16

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

 

Output
Output the sum of the maximal sub-rectangle.
 

 

Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
 

 

Sample Output
15
 

 

[cpp] 
/*
题目大意:给定一个含有正数和负数的矩阵,求其子矩阵的和的最大值
 
一维的情况很简单,如何把一维的情况转化为二维情况呢?
例如,对于本题的测试数据:
我们可以每次任选几行,压缩成一行,这样就转化为了一维情况。
例如,我们求1~2行中的最大子矩阵:即矩阵高为2(1~2行),宽为1:4的矩阵,可以先把1~2行相加,得到9 0 -13 2,再求这个单行的最大子段,由此就可以求得1~2行的最大子矩阵。
*/ 
 
#include<stdio.h> 
#include<string.h> 
int max,n; 
int map[105][105],b[105]; 
int dp() 

    int i,sum=0,m=-1000; 
    for(i=0;i<n;i++) 
    { 
        sum=sum+b[i]; 
        if(sum<0) sum=0; 
        if(sum>m) m=sum; 
    } 
    return m; 
     

int main() 

    int i,j,k,t,ans; 
    while(scanf("%d",&n)!=EOF) 
    { 
        for(i=0;i<n;i++) 
            for(j=0;j<n;j++) 
                scanf("%d",&map[i][j]); 
            max=0;//一开始没有初始化 没法和后面的比较大小啊  所以WA了  所以要注意也谢细节问题 
            for(i=0;i<n;i++)//从第几行开始 
            { 
                for(k=0;k<n;k++)//行数 
                { 
                    if(i+k<n) 
                    { 
                        memset(b,0,sizeof(b)); 
                        for(t=i;t<=i+k;t++) 
                        { 
                            for(j=0;j<n;j++) 
                               b[j]+=map[t][j]; 
                        } 
                        ans=dp(); 
                        max=max>ans?max:ans; 
                    } 
                } 
            } 
            printf("%d\n",max);  
    } 
    return 0; 

作者:hnust_xiehonghao
 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,