当前位置:编程学习 > C/C++ >>

PAT-1011. World Cup Betting (20)

题目描述:
With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.
Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.
For example, 3 games' odds are given as the following:
 W    T    L
1.1  2.5  1.7
1.2  3.0  1.6
4.1  1.2  1.1
To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).
Input
Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.
Output
For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.
Sample Input
1.1 2.5 1.7
1.2 3.0 1.6
4.1 1.2 1.1
Sample Output
 T T W 37.98
 
分析:简单题。照着题目给出的公式计算就可以。
 
 
#include<iostream>  
#include<string.h>  
#include<iomanip>  
using namespace std;  
  
float MAX(float a,float b){  
    if(a>b) return a;  
    else return b;  
}  
  
int main()  
{  
    float game[3];  
    float max[3];  
    int pos[3];  
    int i,j;  
    float profit = 1.0;  
    memset(max,0,sizeof(max));  
    for(j=0; j<3; j++)  
    {  
        for(i=0; i<3; i++){  
            cin>>game[i];  
            if(game[i] > max[j]) {  
                max[j] = game[i];  
                pos[j] = i;  
            }  
        }  
    }  
  
    for(j=0; j<3; j++){  
        switch(pos[j]){  
        case 0: {cout<<"W "; break;}  
        case 1: {cout<<"T "; break;}  
        case 2: {cout<<"L "; break;}  
        default: break;  
        }  
        //cout<<max[j]<<endl;  
        profit *= max[j];  
    }  
  
    profit =(float)( (profit*0.65 - 1.0) * 2.0 );  
        <span style="color:#FF0000;">//不懂为什么用cout输出的精度不对,用printf就可以</span>  
    //cout<<setprecision(2)<<setiosflags(ios::fixed)<<profit<<endl;  
    printf("%.2f\n",profit);  
  
    return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,