当前位置:编程学习 > C/C++ >>

PAT-1008. Elevator (20)

题目描述:
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.
Output Specification:
For each test case, print the total time on a single line.
Sample Input:
3 2 3 1
Sample Output:
41
 
分析:简单题。电梯上升要6s,下降要4s,每个stop停靠5s,相加就好。
 
 
 
#include<iostream>  
using namespace std;  
  
int main()  
{  
    int N;  
    cin>>N;  
    int now = 0,next = 0,total = 0;  
    while(N--){  
        cin>>next;  
        if(next > now){  
            total += (next - now) * 6 + 5;  
        }         
        else  
            total += (now - next) * 4 + 5;  
        now = next;  
    }  
    cout<<total<<endl;  
    return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,