当前位置:编程学习 > C/C++ >>

Message Flood - 第9届中山大学程序设计竞赛预选赛

题目描述
Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.
输入
There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.
输出
For each case, print one integer in one line which indicates the number of left friends he must send.
示例输入
 
5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0
 
示例输出
 
3
 
 
字典树。。
 
[cpp]  
#include <stdio.h>  
#include <string.h>  
#include <malloc.h>  
  
typedef struct NODE  
{  
    short IsEnd;  
    short IsShow;  
    struct NODE *pNext[30];  
}NODE,*PNODE;  
  
  
void Init(PNODE *pRoot);  
void Delete(PNODE pRoot); /* 删除树 */  
PNODE CreateNode(); /* 创建新结点 */  
void Insert(PNODE *pRoot,char *s); /* 插入 */  
int Search(PNODE *pRoot,char *s); /* 查找 */  
char ToLow(char c); /* 输入转化为小写字母 */  
  
int main()  
{  
    PNODE pRoot = NULL;  
    Init(&pRoot);  
  
    char list[50];  
    int N,M;  
    int n,m;  
    int tot;  
    while(scanf("%d",&N) != EOF && N)  
    {  
        n = N;  
        scanf("%d",&M);  
        m = M;  
        tot = 0;  
  
        while(n--)  
        {  
            scanf("%s",list);  
            Insert(&pRoot,list);  
        }  
  
        while(m--)  
        {  
            scanf("%s",list);  
            if(Search(&pRoot,list))  
                tot++;  
        }  
  
        printf("%d\n",N - tot);  
        Delete(pRoot);  
        Init(&pRoot);  
  
    }  
  
    return 0;  
}  
  
char ToLow(char c)  
{  
    if(c >= 'A' && c <= 'Z')  
        return c + 32;  
    return c;  
}  
  
void Delete(PNODE pRoot)  
{  
    int i;  
  
    for(i = 0 ; i < 30 ; ++i)  
    {  
        if(pRoot->pNext[i] != NULL)  
            Delete(pRoot->pNext[i]);  
    }  
  
    free(pRoot);  
}  
  
int Search(PNODE *pRoot,char *s)  
{  
    int i,k;  
    PNODE p = *pRoot;  
  
    if(!p)  
        return 0;  
  
    i = 0;  
    while(s[i])  
    {  
        k = ToLow(s[i++]) - 'a';  
        if(!p->pNext[k]) /* 没有出现过 */  
            return 0;  
        p = p->pNext[k];  
    }  
  
    if(1 == p->IsEnd && 0 == p->IsShow)  
    {  
        p->IsShow = 1;  
        return 1;  
    }  
    else  
        return 0;  
}  
  
void Insert(PNODE *pRoot,char *s)  
{  
    PNODE p = *pRoot;  
    int i,k;  
  
    if(!p)  
        p = *pRoot = CreateNode();  
  
    i = 0;  
    while(s[i])  
    {  
        /* 找到相应的分支 */  
        k = ToLow(s[i++]) - 'a';  
  
        if(!p->pNext[k]) /* 如果此孩子为空,则创建 */  
        {  
            p->pNext[k] = CreateNode();  
        }  
        p = p->pNext[k];  
    }  
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,