当前位置:编程学习 > C/C++ >>

杭电OJ——1220 Cube(详细解答)

Cube
 
Problem Description
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.
 
Process to the end of file.
 
 
Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
 
 
Output
For each test case, you should output the number of pairs that was described above in one line.
 
 
Sample Input
1
2
3
 
 
Sample Output
0
16
297
 
Hint
Hint
 
The results will not exceed int type.
 
 
Author
Gao Bo
 
 
Source
杭州电子科技大学第三届程序设计大赛
 
 
Recommend
Ignatius.L
 
这纯粹是一道数学题目,推理如下:
 给你一个正方体,切割成单位体积的小正方体,求所有公共顶点数<=2的小正方体的对数。
公共点的数目只可能有:0,1,2,4.
很明显我们用总的对数减掉有四个公共点的对数就可以了。
 
总的公共点对数:n^3*(n^3-1)/2(一共有n^3块小方块,从中选出2块)(只有两个小方块之间才存在公共点,我们从所有的小方块中任意选出两个,自然就确定了这两个小方块的公共点的对数,从所有小方块中任意选取两个,总得选取方法数就是所有种类对数数目的总和!)
 
公共点为4的对数:一列有n-1对(n个小方块,相邻的两个为一对符合要求),一个面的共有 n^2列,底面和左面,前面三个方向相同,同理可得,故总数为:3*n^2(n-1)
所以结果为:n^3 * (n^3-1) - 3*n^2(n-1)
代码如下:
[cpp]  
#include<iostream>  
using namespace std;  
  
int main()  
{  
    int num,sum;  
    while(scanf("%d",&num)!=EOF)  
    {  
        sum=num*num*num*(num*num*num-1)/2-3*num*num*(num-1);  
        cout<<sum<<endl;  
    }  
    return 0;  
}  
 
补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,