当前位置:编程学习 > C/C++ >>

HDU 1312Red and Black(简单搜索 bfs或dfs)

Red and Black
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6908    Accepted Submission(s): 4387
 
 
Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
 
Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 
 
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
 
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
 
'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 
 
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 
 
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
 
 
Sample Output
45
59
6
13
 
 
Source
Asia 2004, Ehime (Japan), Japan Domestic
 
 
 
 
题目意思就不多说了,很容易理解,@为起点,可以上下左右四个方向扩展,
只能走点,问可以到达多少个位置。
 
 
 
 
DFS AC代码:
 
#include<iostream>  
#include<cstring>  
#include<string>  
#include<cstdio>  
using namespace std;  
int r,c;  
int dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};  
char s[25][25];  
int visi[25][25];  
  
void dfs(int a,int b)  
{  
    int i;  
    for(i=0;i<4;i++)  
    {  
        int ta,tb;  
        ta=a+dir[i][0],tb=b+dir[i][1];  
        if(ta>=0&&ta<r&&tb>=0&&tb<c)  
        {  
            if(!visi[ta][tb]&&s[ta][tb]=='.')  
            {  
                visi[ta][tb]=1;  
                dfs(ta,tb);  
            }  
        }  
    }  
}  
  
int main()  
{  
    int i,j;  
    while(scanf("%d%d",&c,&r))  
    {  
        if(!r&&!c) break;  
        memset(visi,0,sizeof(visi));  
        for(i=0;i<r;i++)  
            scanf("%s",s[i]);  
        int a,b;  //把起点的位置找到  
        for(i=0;i<r;i++)  
            for(j=0;j<c;j++)  
                if(s[i][j]=='@')  
                {  
                    a=i,b=j;  
                    break;  
                }  
        visi[a][b]=1;  
        dfs(a,b);  
  
        int res=0;  //统计访问的个数  
        for(i=0;i<r;i++)  
            for(j=0;j<c;j++)  
                if(visi[i][j]==1)  
                    res++;  
        printf("%d\n",res);  
    }  
    return 0;  
}  

 

 
  
//0MS  
 
 
BFS AC代码:
 
#include<iostream>  
#include<cstring>  
#include<string>  
#include<cstdio>  
#include<queue>  
using namespace std;  
int r,c;  
int dir[4][2]={{0,-1},{0,1},{1,0},{-1,0}};  
char s[25][25];  
int visi[25][25];  
  
void bfs(int t)  
{  
    queue<int> mq;  
    mq.push(t);  
    while(!mq.empty())  
    {  
        int p=mq.front();  
        mq.pop();  
        int ta=p/c,tb=p%c;  
        for(int i=0;i<4;i++)  
        {  
            int tta=dir[i][0]+ta,ttb=dir[i][1]+tb;  
            if(tta>=0&&tta<r&&ttb>=0&&ttb<c)  
            {  
                if(!visi[tta][ttb]&&s[tta][ttb]=='.')  
                {  
                    visi[tta][ttb]=1;  
                    mq.push(tta*c+ttb);  
                }  
            }  
        }  
    }  
}  
  
int main()  
{  
    int i,j;  
    while(scanf("%d%d",&c,&r))  
    {  
        if(!r&&!c) break;  
        memset(visi,0,sizeof(visi));  
        for(i=0;i<r;i++)  
            scanf("%s",s[i]);  
        int a,b;  //把起点的位置找到  
        for(i=0;i<r;i++)  
            for(j=0;j<c;j++)  
                if(s[i][j]=='@')  
                {  
                    a=i,b=j;  
                    break;  
                }  
        visi[a][b]=1;  
        bfs(a*c+b);  
  
        int res=0;  //统计访问的个数  
        for(i=0;i<r;i++)  
            for(j=0;j<c;j++)  
                if(visi[i][j]==1)  
                    res++;  
        printf("%d\n",res);  
    }  
    return 0;  
}  
  
//15MS  

 


补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,