当前位置:编程学习 > C/C++ >>

POJ 1207 The 3n + 1 problem

一、题目信息
The 3n + 1 problem
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 44458   Accepted: 13979
Description www.zzzyk.com

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be 易做图yzing a property of an algorithm whose classification is not known for all possible inputs.
Consider the following algorithm:
 

  1.    input n

 

  2.    print n

 

  3.    if n = 1 then STOP

 

  4.       if n is odd then   n <-- 3n+1

 

  5.       else   n <-- n/2

 

  6.    GOTO 2

 


Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed before the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.


Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 10,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.
Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).
Sample Input

1 10
100 200
201 210
900 1000
Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174

二、算法分析
    首先,开一个10000的数组,将所有1~9999的cycle length求出来,之后再根据输入的范围求最大值。这里要特别注意的是,输入的范围,并不一定是i<j的,还有可能是i>j,此时,应该要将i,j交换之后再求最大值。
    我们在求cycle length的时候,可以利用我们已经求过的length。

三、参考代码
[cpp] 
#include <stdio.h> 
#include <string.h> 
int seq[10000],len; 
int count_q(int n) 

    int res = 0; 
    while(1) 
    { 
        if(n == 1) 
        {res++;break;} 
        else if(n < 10000 && seq[n]) 
        {res += seq[n];break;} 
        else if(n&1) 
        {res++;n = 3*n + 1;} 
        else 
        {res++;n = n>>1;} 
    } 
    return res; 

int maxww(int beg,int end) 

    int tmp,i; 
    int res = seq[beg]; 
    if(beg > end) 
        tmp = beg,beg = end,end = tmp; 
    for(i = beg+1; i <= end; i++) 
        seq[i] > res ? res = seq[i] : 0; 
    return res; 

int main(int argc , char * argv[]){ 
    int i,j,beg,end; 
    memset(seq,0,10000*sizeof(int)); 
    for(i = 1;i < 10000 ; i++){    
        if(!seq[i]){ 
            seq[i] = count_q(i); 
            for(j = i << 1,len = seq[i]+1 ; j < 10000; j = j << 1,len++) 
                !seq[j] ? seq[j] = len :0 ; 
        } 
    }    
    while(scanf("%d%d",&beg,&end)!=EOF) 
        printf("%d %d %d\n",beg,end,maxww(beg,end)); 
    return 0; 


   

 


 

补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,