当前位置:编程学习 > C/C++ >>

HDUacm 1001 Sum Problem

Problem Description
    Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
    In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
    The input will consist of a series of integers n, one integer per line.
Output
    For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
    1 100
Sample Output
    1 5050
 
Codes:
 1 #include <stdio.h>
 2 main()
 3 {
 4     int a,i,sum;
 5    
 6     while(scanf("%d",&a)!=EOF)
 7     {
 8         sum=0;
 9         for(i=1;i<=a;i++)
10             sum=sum+i;
11         printf("%d\n\n",sum);
12     }
13 }
复制代码

 作者 任琦磊
 

补充:软件开发 , C语言 ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,