当前位置:编程学习 > C/C++ >>

HDU 3367 Pseudoforest (伪森林)


题目:
Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
 

Output
Output the sum of the value of the edges of the maximum pesudoforest.
 

Sample Input
3 3
0 1 1
1 2 1
2 0 1
4 5
0 1 1
1 2 1
2 3 1
3 0 1
0 2 2
0 0
 

Sample Output
3
5
 

Source
“光庭杯”第五届华中北区程序设计邀请赛 暨 WHU第八届程序设计竞赛


分析与总结:
这题题意理解了好一阵子才明白,  给出一个图,要求出最大的pseudoforest, 所谓pseudoforest就是指这个图的一个子图,这个子图的每个连通分量中最多只能有一个环, 而且这个子图的所有权值之和最大。这个就是所谓的伪森林。

过程类似与kruskal求最小生成树,千万不要直接求最大生成树,一开始时我想到的方法是用kruskal算法求出这个图的最大生成树, 然后给每一棵数再加上一条最大的边,构成一个环。 但是WA得快吐血了。

正确的做法和求最大生成树很类似,但是有一点改变, 因为每个连通分量允许有一个回环, 所以,我们可以在进行合并两颗树时,要判断这两颗树是否有回环,如果两个树都有回环,那么明显不可以合并这两颗树, 如果只有一棵树有回环,那么可以合并,然后标上记号。如果两个都没有回环,那么就直接合并了。
如果有两个点是属于同一棵树上的,那么判断这棵树上是否已有回环,如果没有的话,那么允许有一个回环,可以链接这两点,再标上记号。
具体看代码。


代码:
[cpp] 
#include<cstdio> 
#include<cstring> 
#include<algorithm> 
#define N 10005 
using namespace std; 
 
struct Edge{ 
    int u,v,val; 
    friend bool operator<(const Edge&a,const Edge&b){ 
        return a.val>b.val; 
    } 
}arr[N*10]; 
 
int f[N],rank[N],vis[N],n,m; 
 
void init(){ 
    for(int i=0; i<=n; ++i) 
        f[i]=i, rank[i]=0; 

int find(int x){ 
    int i,j=x; 
    while(j!=f[j]) j=f[j]; 
    while(x!=j){ i=f[x]; f[x]=j; x=i; } 
    return j; 

 
void Union(int x,int y){ 
    int a=find(x),b=find(y); 
    if(a==b) return ; 
    if(rank[a]>rank[b]) 
        f[b]=a; 
    else{ 
        if(rank[a]==rank[b]) 
            ++rank[b]; 
        f[a]=b; 
    } 

 
 
int main(){ 
    while(~scanf("%d%d",&n,&m)){ 
        if(!n&&!m)break; 
        for(int i=0; i<m; ++i) 
            scanf("%d%d%d",&arr[i].u,&arr[i].v,&arr[i].val); 
        init(); 
        sort(arr,arr+m); 
        memset(vis, 0, sizeof(vis)); 
        long long ans=0; 
        for(int i=0; i<m; ++i){ 
            int a=find(arr[i].u), b=find(arr[i].v); 
            if(a!=b){ 
                if(vis[a]&&vis[b]) continue;//两个都有环了 
                if(vis[a]||vis[b]) vis[a]=vis[b]=1; 
                ans += arr[i].val; 
                Union(a,b); 
            } 
            else if(!vis[a]){ // 虽然是同一棵数,但是还没有环 
                Union(a,b); 
                vis[a] = 1; 
                ans+=arr[i].val; 
            } 
        }  
         
        printf("%lld\n", ans); 
    } 
    return 0; 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,