当前位置:编程学习 > C/C++ >>

hdu 1029 map做法

Ignatius and the Princess IV
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32767 K (Java/Others)
Total Submission(s): 9654    Accepted Submission(s): 3785


Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1
 

Sample Output
3
5
1
 
题意:输入n个数  n为奇数  问某个数出现的次数大于等于(N+1)/2的是 哪个  输出来
 
思路  map记录
 
[cpp] 
#include<stdio.h> 
#include<map> 
#include<iostream> 
using namespace std; 
map<int,int>mp; 
int main() 

    int i,j,n,N; 
    while(scanf("%d",&n)!=EOF) 
    { 
        N=n; 
        mp.clear(); 
        while(n--) 
        { 
        scanf("%d",&i); 
        mp[i]++; 
        } 
        map<int,int>::iterator it; 
        printf("cc"); 
        for(it=mp.begin();it!=mp.end();i++) 
        { 
            if(it->second>=(N+1)/2) {printf("%d\n",it->first);break;} 
        } 
    } 
    return 0; 
 

 
 

补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,