杭电OJ——1114 Piggy-Bank(完全背包)
Piggy-BankProblem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is 易做图. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
Source
Central Europe 1999
Recommend
Eddy
完全背包问题,不懂的可以去看看背包九讲!
代码如下:
[cpp]
//完全没有想到,这道题目居然是一个完全背包问题!
/*
#include<iostream>
#include<algorithm>
using namespace std;
struct Coin
{
int num,weight;
float scale;
};
bool cmp(Coin a,Coin b)
{
return a.scale>b.scale;
}
int main()
{
Coin coin[100];
int num,sum,i;
cin>>num;
while(num--)
{
int e,t,temp,a;
int cases;
cin>>e>>t>>cases;
for(i=0;i<cases;i++)
{
cin>>coin[i].num>>coin[i].weight;
coin[i].scale=(float)coin[i].weight/(float)coin[i].num;
}
sort(coin,coin+cases,cmp);
temp=t-e;
if(temp<0)
{
cout<<"This is impossible."<<endl;
continue;
}
sum=0;
for(i=0;i<cases;i++)
{
a=temp/coin[i].weight;
temp=temp-coin[i].weight*a;
sum=sum+coin[i].num*a;
}
//if(temp!=0)
//cout<<"This is impossible."<<endl;
//else
printf("The minimum amount of money in the piggy-bank is %d.\n",sum);
}
return 0;
}
*/
/*
#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
int t,e,f,p[501],w[501],n,k[10001],fe;
cin>>t;
while(t--)
{
cin>>e>>f>>n;
fe = f - e;
for(int i = 0; i < n ; i++)
{
cin>>p[i]>>w[i];
}
k[0] = 0;
//完全背包的初始化!
for(int i = 1 ; i <= fe;i++)
{
k[i] = 50000000;
}
for(int i = 0 ; i < n ; i++)//选取硬币的种数
{
for(int m = w[i] ; m <= fe;m++)//重量
{
if(k[m-w[i]]+p[i]<k[m])//选取最小的
k[m] = k[m-w[i]] + p[i];
}
}
&nbs
补充:软件开发 , C++ ,
- 更多C/C++疑问解答:
- 关于c++的cout输出的问题。
- 在学校里学过C和C++,不过学的很一般,现在自学C#,会不会很难?
- 全国计算机二级C语言笔试题
- 已知某树有2个2度结点,3个3度结点,4个4度结点,问有几个叶子结点?
- c++数据结构内部排序问题,整数排序
- 2012九月计算机二级C语言全国题库,,急求急求
- 如果assert只有一个字符串作为参数,是什么意思呢?
- C语言中,哪些运算符具有左结合性,哪些具有右结合性,帮忙总结下,谢谢了!
- 为什么用结构体编写的程序输入是,0输不出来啊~~~
- 将IEEE—754的十六进制转化为十进制浮点类型,用C或C++都行,多谢各位大侠啊,非常感谢!
- 为什么这个程序求不出公式?
- 这个链表倒置的算法请大家分析下
- c语言函数库调用
- C语言unsigned int纠错
- C语言快排求解啊