当前位置:编程学习 > C/C++ >>

POJ 3270 Cow Sorting

Cow Sorting
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5433 Accepted: 2040
Description
Farmer John's N (1 ≤ N ≤ 10,000) cows are lined up to be milked in the evening. Each cow has a unique "grumpiness" level in the range 1...100,000. Since grumpy cows are more likely to damage FJ's milking equipment, FJ would like to reorder the cows in line so they are lined up in increasing order of grumpiness. During this process, the places of any two cows (not necessarily adjacent) can be interchanged. Since grumpy cows are harder to move, it takes FJ a total of X+Y units of time to exchange two cows whose grumpiness levels are X and Y.
Please help FJ calculate the minimal time required to reorder the cows.
Input
Line 1: A single integer: N. 
Lines 2..N+1: Each line contains a single integer: line i+1 describes the grumpiness of cow i. 
Output
Line 1: A single line with the minimal time required to reorder the cows in increasing order of grumpiness.
Sample Input
3
2
3
1
Sample Output
7
Hint
2 3 1 : Initial order. 
2 1 3 : After interchanging cows with grumpiness 3 and 1 (time=1+3=4). 
1 2 3 : After interchanging cows with grumpiness 1 and 2 (time=2+1=3).
Source
USACO 2007 February Gold
    想到置换的循环分解,
比如2 3 1
       1 2 3 于是用循环分解表示则是(1,3,2)最小值就等于1+3+1+2=7,一个()内必须以最小的开始才能达到最小。但这样还是有错误,因为()内最小的值可能比整个数组中最小值大,我们可以先将这两个值换过来,最后在换过去,这样可能比原来的时候小,这是有可能的。
 
#include <iostream>  
#include <algorithm>  
#include <cstring>  
#include <cstdio>  
#include <cmath>  
#define N 100010  
#define M 10010  
#define INF 0x7ffffff  
using namespace std;  
int a[M],b[M],pt[N],c[M];  
bool ch[N];  
int main()  
{  
    //freopen("data.in","r",stdin);  
    int n;  
    while(scanf("%d",&n)!=EOF)  
    {  
        int Mmin=INF;  
        for(int i=0;i<=n-1;i++)  
        {  
            scanf("%d",&a[i]);  
            b[i] = a[i];  
            Mmin = min(Mmin,a[i]);  
        }  
        sort(b,b+n);  
        for(int i=0;i<=n-1;i++)  
        {  
            pt[a[i]] = i;  
        }  
        memset(ch,false,sizeof(ch));  
        __int64 ans=0;  
        for(int i=0;i<=n-1;i++)  
        {  
            int x = a[i];  
            if(ch[x])  
            {  
                continue;  
            }  
            ch[x] = true;  
            int Top=0;  
            c[Top++] = x;  
            int j = i;  
            while(true)  
            {  
                int y = b[j];  
                if(ch[y])  
                {  
                    break;  
                }  
                c[Top++] = y;  
                ch[y] = true;  
                j = pt[y];  
            }  
            if(Top==1)  
            {  
                continue;  
            }  
            int Min = INF;  
            __int64 res1=0,tag;  
            for(int u=0;u<=Top-1;u++)  
            {  
                res1+=(__int64)(c[u]);  
                Min = min(Min,c[u]);  
            }  
            tag = res1;  
            res1+=(__int64)(Top-2)*(__int64)Min;  
            __int64 res2 = INF;  
            if(Min!=Mmin)  
            {  
                res2 = tag-Min+Mmin+(__int64)(Top-2)*(__int64)Mmin+(__int64)((Min+Mmin)*2);  
            }  
            __int64 res = min(res1,res2);  
            ans+=(__int64)res;  
        }  
        cout<<ans<<endl;  
    }  
    return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,