当前位置:编程学习 > C/C++ >>

HDU3280:Cheapest Palindrome(区间DP)

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.
Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.
Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800Sample Output

900Hint

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
 
 
题意:给你一个字符串,字符串每个字母都有删除与添加的一个价值,要求通过添加与删除一些字母,将这个字符串变成回文串所需要的最小价值
如样例:删除a,得到bcb,价值为1100
添加a,变成abcba,价值为1000
而添加bcb,变成bcbabcb,价值为900,所以最优为900
 
思路:先将删除或添加的最小价值存入数组,然后再用区间DP的思想去解决
 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,m,i,j,x,y;
int dp[2005][2005],cost[28];
char str[2005],c[2];

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
        scanf("%s",str);
        for(i = 0; i<n; i++)
        {
            scanf("%s%d%d",c,&x,&y);
            cost[c[0]-'a'] = min(x,y);
        }
        for(j = 1; j<m; j++)
        {
            for(i = j-1; i>=0; i--)//求出每个区间的价值,保存最小的价值
            {
                dp[i][j] = min(dp[i+1][j]+cost[str[i]-'a'],dp[i][j-1]+cost[str[j]-'a']);
                if(str[i]==str[j])
                    dp[i][j] = min(dp[i][j],dp[i+1][j-1]);
            }
        }
        printf("%d\n",dp[0][m-1]);
    }

    return 0;
}

 

补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,