当前位置:编程学习 > C/C++ >>

hdu4576Robot

 
Robot
Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 1783    Accepted Submission(s): 655
 
 
Problem Description
Michael has a telecontrol robot. One day he put the robot on a loop with n cells. The cells are numbered from 1 to n clockwise.
 
 
 
 
At first the robot is in cell 1. Then Michael uses a remote control to send m commands to the robot. A command will make the robot walk some distance. Unfortunately the direction part on the remote control is broken, so for every command the robot will chose a direction(clockwise or anticlockwise) randomly with equal possibility, and then walk w cells forward.
Michael wants to know the possibility of the robot stopping in the cell that cell number >= l and <= r after m commands.
 
 
Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains four integers: above mentioned n(1≤n≤200) ,m(0≤m≤1,000,000),l,r(1≤l≤r≤n).
Then m lines follow, each representing a command. A command is a integer w(1≤w≤100) representing the cell length the robot will walk for this command.  
The input end with n=0,m=0,l=0,r=0. You should not process this test case.
 
 
Output
For each test case in the input, you should output a line with the expected possibility. Output should be round to 4 digits after decimal points.
 
 
Sample Input
3 1 1 2
1
5 2 4 4
1
2
0 0 0 0
 
 
Sample Output
0.5000
0.2500
 
 
Source
2013ACM-ICPC杭州赛区全国邀请赛
 
 
Statistic | Submit | Discuss | Note
 
 
做这道题时我很无语,因为是挑一道最简单的题来做,但是自己真的很菜,很水!!
 
明知道这道题是水题都是在看到人家的结题报告才知道这是概率dp。
 
对自己的水平很失望。。
 
还有我看到dp的循环次数时以为会超时(一百万*2*200)这样都不超时,Orz~~Orz~~Orz~~Orz~~Orz!!
 
用b数组代表是这个状态,a数组代表是上一个状态 然后有
 
b[(j-w+n)%n]+= a[j]*0.5;
b[(j+w)%n]+= a[j]*0.5;
 
 
 
 
 
#include<cstdio>  
#include<cstring>  
double a[212],b[212];  
int main()  
{  
    int n,m,l,r,w,j;  
    double va;  
    while(scanf("%d%d%d%d",&n,&m,&l,&r))  
    {  
        if(n+m+l+r==0)  
        break;  
        memset(a,0,sizeof(a));  
        memset(b,0,sizeof(b));  
        a[0] = 1.0;  
        for(int i=0;i<m;i++)  
        {  
            scanf("%d",&w);  
            for(j=0;j<n;j++)  
            {  
                if(a[j]>0)//记住一定要这个剪枝,不然就很容易超时   
                {  
                va = a[j]*0.5;  
                b[(j-w+n)%n]+= va;  
                b[(j+w)%n]+= va;  
                }      
            }    
            for(j=0;j<n;j++)  
            {  
                a[j] = b[j];  
                b[j] = 0;   //还有易做图这个一定要初始化为0,不然就会错。   
            }        
              
        }      
        l--;  
        r--;  
        double ans = 0.0;  
        for(;l<=r;l++)  
        ans+=a[l];  
        printf("%0.4f\n",ans);  
    }      
    return 0;  
}      

 

 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,