当前位置:编程学习 > C/C++ >>

蛇形填数

描述
在n*n方陈里填入1,2,...,n*n,要求填成蛇形。例如n=4时方陈为:
10 11 12 1
9 16 13 2
8 15 14 3
7 6 5 4

输入
直接输入方陈的维数,即n的值。(n<=100)
输出
输出结果是蛇形方陈。
样例输入
3样例输出
7 8 1
6 9 2
5 4 3

分析:告诉我们一个n后,我们就知道这个蛇形填数填到最后一个数必是n*n,所以循环的截止条件是<=n*n 。循环的过程是在一个二维数组中从起点开始向下走,到边界后又向左走,到边界后又向上走,再想右走,在循环下去。定义一个教大的二维数组时,最好是定义到main()函数外,此题最好用memset()函数对数组进行初始化,每个数组成员赋初值0,这样可以在循环填数时,也作为一个边界条件。

 

 

[cpp] 
#include <iostream>  
#include <stdlib.h>   
#include <stdio.h>  
#include <string.h>   
using namespace std; 
#define  MAX 100  
int a[MAX][MAX]; 
int main() 

    int x,y,n,m,tot=0;    
    memset(a,0,sizeof(a));    
    cin>>n; 
    tot=a[x=0][y=n-1]=1; 
    while(tot<n*n) 
    {   //cout<<"****"<<endl;  
        while(x+1<n&&!a[x+1][y])  a[++x][y]= ++tot;  //下走   
        while(y-1>=0&&!a[x][y-1])  a[x][--y]= ++tot;   //左走  
        while(x-1>=0&&!a[x-1][y])  a[--x][y]= ++tot;    //上走  
        while(y+1<n&&!a[x][y+1])  a[x][++y]= ++tot;    //右走  
    } 
    for(x=0;x<n;x++) 
    { 
       for(y=0;y<n;y++) 
         printf("%d ",a[x][y]); 
        //cout<<a[x][y]<<' ';  
        cout<<endl; 
    } 
    //system("pause");  
    return 0; 
}  

#include <iostream>
#include <stdlib.h>
#include <stdio.h>
#include <string.h>
using namespace std;
#define  MAX 100
int a[MAX][MAX];
int main()
{
    int x,y,n,m,tot=0;  
    memset(a,0,sizeof(a));  
    cin>>n;
    tot=a[x=0][y=n-1]=1;
    while(tot<n*n)
    {   //cout<<"****"<<endl;
        while(x+1<n&&!a[x+1][y])  a[++x][y]= ++tot;  //下走
        while(y-1>=0&&!a[x][y-1])  a[x][--y]= ++tot;   //左走
        while(x-1>=0&&!a[x-1][y])  a[--x][y]= ++tot;    //上走
        while(y+1<n&&!a[x][y+1])  a[x][++y]= ++tot;    //右走
    }
    for(x=0;x<n;x++)
    {
       for(y=0;y<n;y++)
         printf("%d ",a[x][y]);
        //cout<<a[x][y]<<' ';
        cout<<endl;
    }
    //system("pause");
    return 0;
}


 

补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,