当前位置:编程学习 > C/C++ >>

PAT-1051. Pop Sequence (25)

题目描述:
Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.
Output Specification:
For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.
Sample Input:
5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:
YES
NO
NO
YES
NO
分析:
考察栈的操作。
输入的序号是1,2,3......N。
5 6 4 3 7 2 1
为例,要pop 5,就必须先push 1, push 2, push 3, push 4, push5, 此时栈顶元素为5,刚好匹配,所以进行pop操作。
设置一个变量temp,由1开始自增。当栈顶元素与输入的元素不匹配且栈元素个数未满M时就进行入栈操作:sta.push(temp++);。
如果栈中的元素超过了M值,则说明出现了错误,这种出栈方式是不对的。
参考:
http://blog.dayandcarrot.net/2013/05/1051-pop-sequence-25/
http://tech-wonderland.net/blog/pat-1051-pop-sequence.html
http://blog.csdn.net/sunbaigui/article/details/8656793
 
参考代码:
 
#include<iostream>  
#include<stack>  
using namespace std;  
  
int _tmain(int argc, _TCHAR* argv[])  
{  
    int M; //maximum capacity of the stack  
    int N; //the length of push sequence  
    int K; //the number of pop sequence to be checked  
    cin>>M>>N>>K;  
    int i,j;  
    int input,temp;  
    bool flag = true;  
    stack<int> sta;  
      
    for(i=0; i<K; i++)  
    {  
        temp = 1;  
        flag = true;  
        for(j=0; j<N; j++)  
        {  
            cin>>input;  
            while( sta.size() <= M && flag )  
            {  
                if(sta.empty() || sta.top() != input)  
                {  
                    sta.push(temp ++);  
                }  
                else if(sta.top() == input)  
                {  
                    sta.pop();  
                    break;  
                }             
            }  
            if(sta.size() > M)  
            {flag = false;}  
        }  
  
        if(flag)  
            cout<<"YES"<<endl;  
        else   
            cout<<"NO"<<endl;  
        while(!sta.empty())  
            sta.pop();  
    }  
    return 0;  
}  

 

 
 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,