当前位置:编程学习 > C/C++ >>

HDU2560:Buildings

Problem Description
We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.

 

 

\


Input
Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.


 


Output
Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.
 


Sample Input
2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0


Sample Output
2
5

 

题目那么长,答案那么水,我都无语了

就是统计方阵里1的个数

 

[cpp]
#include <iostream>  
using namespace std; 
 
int main() 

    int t; 
    cin >> t; 
    while(t--) 
    { 
        int a,b,i,j,f,cnt = 0; 
        cin >> a >> b; 
        for(i = 0;i<a;i++) 
        { 
            for(j = 0;j<b;j++) 
            { 
                cin >> f; 
                if(f) 
                cnt++; 
            } 
        } 
        cout << cnt << endl; 
    } 
 
    return 0; 

#include <iostream>
using namespace std;

int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        int a,b,i,j,f,cnt = 0;
        cin >> a >> b;
        for(i = 0;i<a;i++)
        {
            for(j = 0;j<b;j++)
            {
                cin >> f;
                if(f)
                cnt++;
            }
        }
        cout << cnt << endl;
    }

    return 0;
}


 

补充:软件开发 , C++ ,
CopyRight © 2012 站长网 编程知识问答 www.zzzyk.com All Rights Reserved
部份技术文章来自网络,