当前位置:编程学习 > C/C++ >>

poj3624 Charm Bracelet

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7Sample Output

 01背包问题   
#include<stdio.h>   
 int c[3500],w[3500],f[13000];  int main()  {   
   int i,j,k,n,v,m;   
   while(scanf("%d%d",&n,&m)!=EOF) 
     {          for(i=0;i<=m;i++)         
     f[i]=0;       
   for(i=0;i<n;i++)     
         scanf("%d%d",c+i,w+i);     
     for (i = 0; i < n; ++i)          {        
      for (v = m; v >= c[i]; --v) //c[i]可优化为bound,bound = max {V - sum c[i,...n],c[i]}          
    {                  f[v] = (f[v] > f[v - c[i]] + w[i]?f[v] : f[v - c[i]] + w[i]);           
   }          }          printf("%d\n",f[m]);      }  } 
 01背包问题 
#include<stdio.h>

int c[3500],w[3500],f[13000];
int main()
{
 int i,j,k,n,v,m;
 while(scanf("%d%d",&n,&m)!=EOF)
 {
  for(i=0;i<=m;i++)
   f[i]=0;
  for(i=0;i<n;i++)
   scanf("%d%d",c+i,w+i);
  for (i = 0; i < n; ++i)
  {
   for (v = m; v >= c[i]; --v) //c[i]可优化为bound,bound = max {V - sum c[i,...n],c[i]}
   {
    f[v] = (f[v] > f[v - c[i]] + w[i]?f[v] : f[v - c[i]] + w[i]);
   }
  }
  printf("%d\n",f[m]);
 }
}

 

补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,