当前位置:编程学习 > C/C++ >>

hdu 2602 Bone Collector

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 


 
Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 
Output

One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1
Sample Output

14就是01背包真接上代码
 

#include<stdio.h>  
 int c[3500],w[3500],f[13000];
  int main()  {      int i,j,k,n,v,m,t; 
    scanf("%d",&t);  
   while(t--) 
    {          scanf("%d%d",&n,&m);  
       for(i=0;i<=m;i++)              f[i]=0; 
        for(i=0;i<n;i++)              scanf("%d",w+i);  
       for(i=0;i<n;i++)              scanf("%d",c+i);   
      for (i = 0; i < n; ++i)          {              for (v = m;
 v >= c[i]; --v) //注意这里的V是从大到小c[i]可优化为bound,bound = max {V - sum c[i,...n],c[i]} 
            {                  f[v] = (f[v] > f[v - c[i]] + w[i]?f[v] : f[v - c[i]] + w[i]); 
            }          }          printf("%d\n",f[m]); 
    }      return 0;
 }  #include<stdio.h>

int c[3500],w[3500],f[13000];
int main()
{
 int i,j,k,n,v,m,t;
 scanf("%d",&t);
 while(t--)
 {
  scanf("%d%d",&n,&m);
  for(i=0;i<=m;i++)
   f[i]=0;
  for(i=0;i<n;i++)
   scanf("%d",w+i);
  for(i=0;i<n;i++)
   scanf("%d",c+i);
  for (i = 0; i < n; ++i)
  {
   for (v = m; v >= c[i]; --v) //注意这里的V是从大到小c[i]可优化为bound,bound = max {V - sum c[i,...n],c[i]}
   {
    f[v] = (f[v] > f[v - c[i]] + w[i]?f[v] : f[v - c[i]] + w[i]);
   }
  }
  printf("%d\n",f[m]);
 }
 return 0;
}

 

补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,