九度OJ 题目1029:魔咒词典
题目描述: 哈利波特在魔法学校的必修课之一就是学习魔咒。据说魔法世界有100000种不同的魔咒,哈利很难全部记住,但是为了对抗强敌,他必须在危急时刻能够调用任何一个需要的魔咒,所以他需要你的帮助。
给你一部魔咒词典。当哈利听到一个魔咒时,你的程序必须告诉他那个魔咒的功能;当哈利需要某个功能但不知道该用什么魔咒时,你的程序要替他找到相应的魔咒。如果他要的魔咒不在词典中,就输出“what?”
输入:
首先列出词典中不超过100000条不同的魔咒词条,每条格式为:
[魔咒] 对应功能
其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。
输出:
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果魔咒不在词典中,就输出“what?”
样例输入:
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one's legs
[serpensortia] shoot a snake out of the end of one's wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky样例输出:
light the wand
accio
what?
what?来源:
2008年浙江大学计算机及软件工程研究生机试真题
[cpp]
/*********************************
* 日期:2013-2-18
* 作者:SJF0115
* 题号: 九度OJ 题目1029:魔咒词典
* 来源:http://ac.jobdu.com/problem.php?pid=1029
* 结果:AC
* 来源:2008年浙江大学计算机及软件工程研究生机试真题
* 总结:
**********************************/
#include<map>
#include<string>
#include<iostream>
#include<string.h>
#include <stdio.h>
using namespace std;
map<string,string> Map;
int Function(string str){
int len=str.length();
int i;
for(i = 0;i < len;i++)
{
if(str[i]==']')
{
break;
}
}
//魔咒
string s1 = str.substr(0,i+1);
//对应功能
string s2 = str.substr(i+2,len-i-2);
//存储在Map中
Map[s1] = s2;
Map[s2] = s1;
return 0;
}
int main()
{
char s[105];
int n,i;
string str;
//输入数据
while(gets(s)){
str = s;
if(str == "@END@")
{
break;
}
//分割魔咒及其对应功能
Function(str);
}
scanf("%d\n",&n);
for(i = 0;i < n;i++){
gets(s);
str = s;
//寻找魔咒或者对应功能
if(Map.find(str) == Map.end())
{
printf("what?\n");
}
else
{
str = Map[str];
//输出对应的功能
if(str[0] != '[')
{
cout<<str<<endl;
}
//输出对应的魔咒
else
{
cout<<str.substr(1,str.length()-2)<<endl;
}
}
}//for
return 0;
}
/*********************************
* 日期:2013-2-18
* 作者:SJF0115
* 题号: 九度OJ 题目1029:魔咒词典
* 来源:http://ac.jobdu.com/problem.php?pid=1029
* 结果:AC
* 来源:2008年浙江大学计算机及软件工程研究生机试真题
* 总结:
**********************************/
#include<map>
#include<string>
#include<iostream>
#include<string.h>
#include <stdio.h>
using namespace std;
map<string,string> Map;
int Function(string str){
int len=str.length();
int i;
for(i = 0;i < len;i++)
{
if(str[i]==']')
{
break;
}
}
//魔咒
string s1 = str.substr(0,i+1);
//对应功能
string s2 = str.substr(i+2,len-i-2);
//存储在Map中
Map[s1] = s2;
Map[s2] = s1;
return 0;
}
int main()
{
char s[105];
int n,i;
string str;
//输入数据
while(gets(s)){
str = s;
if(str == "@END@")
{
break;
补充:软件开发 , C++ ,
上一个:Hoj 2183 Extrusion
下一个:c++中的STL基本容器介绍
- 更多C/C++疑问解答:
- 关于c++的cout输出的问题。
- 在学校里学过C和C++,不过学的很一般,现在自学C#,会不会很难?
- 全国计算机二级C语言笔试题
- 已知某树有2个2度结点,3个3度结点,4个4度结点,问有几个叶子结点?
- c++数据结构内部排序问题,整数排序
- 2012九月计算机二级C语言全国题库,,急求急求
- 如果assert只有一个字符串作为参数,是什么意思呢?
- C语言中,哪些运算符具有左结合性,哪些具有右结合性,帮忙总结下,谢谢了!
- 为什么用结构体编写的程序输入是,0输不出来啊~~~
- 将IEEE—754的十六进制转化为十进制浮点类型,用C或C++都行,多谢各位大侠啊,非常感谢!
- 为什么这个程序求不出公式?
- 这个链表倒置的算法请大家分析下
- c语言函数库调用
- C语言unsigned int纠错
- C语言快排求解啊