当前位置:编程学习 > C/C++ >>

POJ2886:Who Gets the Most Candies?(线段树单点更新)

Description
 
N children are sitting in a circle to play a game.
 
The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (−A)-th child to the right.
 
The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?
 
Input
 
There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.
Output
 
Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.
 
Sample Input
 
4 2
Tom 2
Jack 4
Mary -1
Sam 1
Sample Output
 
Sam 3
 
题意:n个熊孩子按顺时针排列,每个人受伤都有一张牌,牌上有一个数字,从第k个孩子开始出队,出队的熊孩子卡上数字是K,则顺时针第k人是下一个出队的,负数则逆时针,第P个出队的会得到的糖果数是p的因子个数,输出得到最多糖果的人和他的糖果数,如果有多个,则输出最闲出队的。
思路:线段树存储的是每个子树中还有几个人,而因子数我们可以用反素数打表求得,所谓的反素数可以参照杭电2521,
 
 
#include <stdio.h>  
#include <string.h>  
#include <algorithm>  
using namespace std;  
//反素数打表  
int s[40] = {1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,1260,1680,2520,5040,7560,10080,15120,20160,25200,27720,45360,50400,55440,83160,110880,166320,221760,277200,332640,498960,500001};  
int b[40] = {1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,64,72,80,84,90,96,100,108,120,128,144,160,168,180,192,200,1314521};  
int k,n;  
  
char name[500005][11];  
int val[500005];  
  
struct node  
{  
    int l,r,n;  
} a[1000000];  
  
void init(int i,int l,int r)  
{  
    a[i].l = l;  
    a[i].r = r;  
    a[i].n = r-l+1;  
    if(l!=r)  
    {  
        int mid = (l+r)>>1;  
        init(2*i,l,mid);  
        init(2*i+1,mid+1,r);  
    }  
}  
  
int insert(int i,int x)  
{  
    a[i].n--;  
    if(a[i].l == a[i].r)  
    {  
        return a[i].l;  
    }  
    if(x<=a[2*i].n)  
        insert(2*i,x);  
    else  
        insert(2*i+1,x-a[2*i].n);  
}  
  
int main()  
{  
    int i,j,maxn,p,pos;  
    while(~scanf("%d%d",&n,&k))  
    {  
        i = 0;  
        while(s[i]<=n)i++;  
        maxn = b[i-1];  
        p = s[i-1];//第P个出队的必然是最多的并且是在得到同样多的MAX糖果中最早出队的,求得其因子数  
        for(i = 1; i<=n; i++)  
            scanf("%s%d",name[i],&val[i]);  
        init(1,1,n);  
        while(p--)//求P个熊孩子即可  
        {  
            n--;  
            pos = insert(1,k);//出队的序号  
            if(!n)  
                break;  
            if(val[pos]>=0)//顺时针  
                k = (k-1+val[pos]-1)%n+1;  
            else//逆时针  
                k = ((k-1+val[pos])%n+n)%n+1;  
        }  
        printf("%s %d\n",name[pos],maxn);  
    }  
  
    return 0;  
}  

 

 
补充:软件开发 , C++ ,
CopyRight © 2022 站长资源库 编程知识问答 zzzyk.com All Rights Reserved
部分文章来自网络,